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Schriftart Bedeutung // Font Conventions 
monospaced Namen von Pfaden und Dateien werden in 

einer Schriftart mit einheitlicher Zeichenbrei-

te dargestellt. Beispiel: notepad.exe 

Names of paths and data files are marked 

with a monospaced font. e.g.: 
notepad.exe 

Menu Menüpunkte werden fett dargestellt: Bei-

spiel: Speichern 

Menu items are marked in bold letters. e.g.: 

Save 

> Ein „Größer als“-Zeichen zwischen zwei 

Namen bedeutet die Auswahl eines Me-

nüpunktes aus einem Menü. Beispiel: Datei 

> Neu 

A greater-than sign between two names 

means the selection of a menu item from a 

menu. e.g.: File > New 

Eingabe Bezeichnungen von Eingabe- oder Aus-

wahlfeldern werden fett dargestellt. Beispiel: 

Wert 

Designation of input or optional fields are 

marked in bold letters, e.g.: Value 

„Wert“ Eingabe- oder Auswahlwerte werden in 

Anführungszeichen dargestellt. Beispiel: 

Geben Sie unter Messbereichsanfang den 

Wert „4 mA“ ein. 

Input or selective values are marked in 

inverted commas. e.g.: Enter the value “4 

mA” under Start of measurement range 

[Button] Schaltflächen und Tastenbeschriftungen auf 

der Tastatur werden fett dargestellt und in 

eckigen Klammern eingefasst. Beispiel: 

[OK] 

Pushbuttons in dialog boxes andy Keys are 

marked with bold letters in square brackets. 

e.g.: [OK] or [F5] 
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1. Einleitung // Introduction 

Das WAGO  I /O  SYSTEM  750 zeichnet 

sich mit seinen mehr als 500 verschiedenen 

Modulen für den feldseitigen Anschluss von 

Sensoren, Aktoren und Kommunikations-

teilnehmer und seine Offenheit gegenüber 

einer Vielzahl von Feldbussystemen aus. 

Diese Flexibilität macht das WAGO I/O Sys-

tem 750 für sehr viele und sehr unterschied-

liche Anwendungsfelder äußerst attraktiv. 

Diese Anleitung zeigt auf, wie das WAGO  

I /O  SYSTEM 750 per EtherCAT mit dem 

CTRLX  CORE verbunden werden kann. 

The WAGO  I /O  SYSTEM 750 is distin-

guished by its more than 500 different mod-

ules for the field-side connection of sensors, 

actuators and communication devices and 

its openness to a wide range of fieldbus 

systems. This flexibility makes the WAGO 

I/O System 750 extremely attractive for 

many and very different fields of application. 

This instruction shows how the WAGO  I /O  

SYSTEM 750 can be connected to the 

CTRLX  CORE via EtherCAT. 

2. Voraussetzungen // Prerequisites 

Diese Anleitung ist basierend auf This instruction has been created based on  

• CTRLX  CORE V1.10  

• CTRLX  CORE  ETHERCAT  MASTER APP  V1.10 

• CTRLX  PLC  ENGINEE RING  V1.10 

• CTRLX  I /O  ENGINEERING  V1.10  

• WAGO_750-0354_22.xml 

und exemplarisch mit folgenden Modulen 

aus dem WAGO  I /O  SYSTEM 750 er-

stellt worden: 

and exemplarily with the following modules 

from the WAGO  I /O  SYSTEM 750: 

• 750-354   Fieldbus Coupler EtherCAT 

• 750-430   8-channel digital input; 24 VDC; 3 ms 

• 750-530   8-channel digital output; 24 VDC; 0.5A 

• 750-559   4-channel analog output; 0..10 VDC 

• 750-468   4-channel analog input; 0..10 VDC; Single-ended 

• 750-600   End module 
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[2.1] WAGO I/O System 750  

3. Schritt-für-Schritt // Step by Step 

3.1 I/O-Konfiguration anlegen // Set up the I/O configuration 

01 CTRLX  CORE Benutzeroberfläche im 

Browser öffnen.5 

Open CTRLX  CORE user interface in 

browser. 

 

 
[3.1] C T R L X  CORE  user interface 
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02 EtherCAT-Master über Betätigung von [+] 

unter EtherCAT > Configuration hinzufü-

gen. 

Add EtherCAT master by clicking [+] in 

EtherCAT > Configuration. 

 

 
[3.2] EtherCAT > Configuration > [+]  

 
[3.3] EtherCAT > Configuration > [+] > [OK] 

03 Das lokal installierte CTRLX  I /O  

ENGINEERING  über Betätigung der Schalt-

Launch the local installed CTRLX  I /O  

ENGINEERING  by clicking on [ctrlX I/O 
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fläche [ctrlX I/O Engineering] öffnen. Engineering]. 

 

 
[3.4] EtherCAT > Configuration > [ctrlX I/O Engineering] 

04 Projektnamen und Ordner, in dem die I/O-

Konfiguration gespeichert werden soll, wäh-

len. 

Choose a project name and a folder where 

the I/O configuration should be saved. 

 

 
[3.5]  Start ctrlX I/O Engineering > Choose a project name and a folder 

05 Sollte nach dem Start des CTRLX  I /O  

ENGINEERINGS  ein Dialog erscheinen, ist 

hier [Use project from ctrlX] zu wählen. 

If a window appears right after the start of 

CTRLX  I /O  ENGINEERIN G ,  please 

choose [Use project from ctrlX]. 
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[3.6] ctrlX I/O Engineering > Project Synchronization 

06 Über Tools > Device Repository… die 

Gerätebeschreibungsdatei 

WAGO_750-0354_22.xml installieren. 

Install the device description file 

WAGO_750-0354_22.xml by selecting 

Tools > Device Repository… 

 

 
[3.7] Tools > Device Repository… 
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[3.8] Tools > Device Repository…> [Install] (Select the WAGO_750-0354_22.xml file to install.) 

 

[3.9] Tools > Device Repository…> [Close] 

07 Aus dem Kontextmenü des Eintrags „ether-

catmaster“ den Menüpunkt Scan for De-

vices… auswählen, um den 750-354 Feld-

buskoppler EtherCAT hinzuzufügen. 

Choose Scan for Devices… from the con-

text menu from the item “ethercatmaster” to 

add the 750-354 Fieldbus Coupler Ether-

CAT. 
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[3.10] “ethercatmaster” > Scan for devices… 

08 [Insert all newly scanned devices] betäti-

gen, und den Dialog mit [OK] schließen. 

Click [Insert all newly scanned devices] 

and close the dialog by clicking on [OK]. 

 

 
[3.11] Scan for Devices… > [Insert all newly scanned devices] 
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[3.12] Scan for Devices… > [OK] 

 
[3.13] ctrlX I/O Engineering with added 750-354 Fieldbus Coupler EtherCAT 

09 „ethercatmaster“ auswählen und die Be-

triebsart im Auswahlfeld State machine > 

Master state after download auf den Wert 

„Pre-OP“ umstellen, um die Konfiguration im 

nächsten Schritt zu übernehmen. 

Select “ethercatmaster” and choose the 

operating mode “Pre-OP” in the field State 

machine > Master state after download to 

apply the configuration in the next step. 
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[3.14] State machine > Master state after download > “Pre-OP” 

10 Konfiguration über Wahl des Eintrags 

Transferring field bus configuration aus 

dem Kontextmenü des Eintrags „ethercat-

master“ übernehmen. 

Die eventuelle Frage nach einem Betriebs-

artenwechsel zu „Init“ ist mit [Yes] zu bestä-

tigen. 

Apply configuration by choosing Transfer-

ring field bus configuration from the con-

text menu of “ethercatmaster”. 

In case of an upcoming question regarding 

the change of the operating mode to “Init” it 

must be confirmed by clicking [Yes]. 

 

 
[3.15] “ethercatmaster” > Transferring field bus configuration 
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[3.16] Confirm the change of the operating mode to “Init” by clicking [Yes] 

11 Aus dem Kontextmenü des Eintrags 

„ethercatmaster“ erneut den Menüpunkt 

Scan for Devices… auswählen, um die 

angeschlossenen Module hinzuzufügen. 

Choose again Scan for Devices… from the 

“ethercatmaster” item’s context menu to add 

the installed modules. 

 

 
[3.17] Scan for Devices… > [Insert all newly scanned devices] 

12 [Insert all newly scanned devices] betäti-

gen und das Fenster mit [OK] schließen. 

Click [Insert all newly scanned devices] 

and close the window by clicking on [OK]. 
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[3.18] Scan for Devices… > [Insert all newly scanned devices] 
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[3.19] Scan for Devices… > [OK] 

 
[3.20] C T R L X  I /O  E N G I N E E R I N G  with added I/O modules 

13 „ethercatmaster“ auswählen und die Be-

triebsart im Auswahlfeld State machine > 

Master state after download auf den Wert 

„OP“ umstellen, um die Konfiguration im 

nächsten Schritt zu übernehmen und die 

Datenübertragung automatisch zu starten. 

Select “ethercatmaster” and choose the 

operating mode “Pre-OP” in the field State 

machine > Master state after download to 

apply the configuration in the next step and 

to start the data cycling automatically. 

 

 
[3.21] State machine > Master state after download > “OP” 

14 Modulkonfiguration über Wahl des Eintrags 

Transferring field bus configuration aus 

dem Kontextmenü des Eintrags „ethercat-

master“ übernehmen. 

Die eventuelle Frage nach einem Betriebs-

artenwechsel zu „Init“ ist mit [Yes] zu bestä-

tigen. 

Apply module configuration by choosing 

Transferring field bus configuration from 

the context menu of “ethercatmaster”. 

In case of an upcoming question regarding 

the change of the operating mode to “Init” 

must be confirmed by clicking [Yes]. 
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[3.22] “ethercatmaster” > Transferring field bus configuration 

 
[3.23] Confirm the change of the operating mode to “Init” by clicking [Yes] 

15 I/O-Konfiguration über File > Save spei-

chern und CTRLX  I /O  ENGINEERING  

beenden. 

Save the I/O configuration via File > Save 

and exit the CTRLX  I /O  ENGINEERING . 

16 Status des EtherCAT-Feldbusses in der 

CTRLX  CORE Benutzeroberfläche unter 

EtherCAT > Status prüfen. 

Check the status of the EtherCAT fieldbus 

in the CTRLX  CORE user interface via 

EtherCAT > Status. 
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[3.24] ctrlX CORE > EtherCAT > Status 

17 Der Datenaustausch kann über System > 

Data Layer geprüft werden. 

In dem Beispiel sind die digitalen Ausgänge 

eins und zwei Hardware-seitig auf die digita-

len Eingänge eins und zwei gebrückt. 

Ein manuelles Setzen der beiden Ausgänge 

„Output_s_.Channel_1_Data_1“ und 

„Output_s_.Channel_2_Data_1“ vom 

„_750_5xx_750_15xx_8b_out“ kann am 

Eingangsmodul 

„_750_4xx_750_14xx_8b_in“ an den Ein-

gängen „Input_s_.Channel_1_Data_1“ und 

„Input_s_.Channel_2_Data_1“ zurückgele-

sen werden. 

The data exchange can be checked using 

the System > Data Layer. 

In this example the digital outputs one and 

two are bridged to the digital inputs one and 

two by hardware. 

A manually override of the both outputs 

“Output_s_.Channel_1_Data_1” and 

“Output_s_.Channel_2_Data_1” of the 

“_750_5xx_750_15xx_8b_out” could be 

read back by the input module 

“_750_4xx_750_14xx_8b_in” at the inputs 

“Input_s_.Channel_1_Data_1” und 

“Input_s_.Channel_2_Data_1”. 
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[3.25] Manually override two outputs… 

 
[3.26] …and read the values back at the bridged inputs. 

3.2 I/O-Signale in der SPS verwenden // Use the I/O signals in the PLC 

18 Das lokal installierte CTRLX  PLC  

ENGINEERING  über Betätigung der Schalt-

fläche [Start ctrlX PLC Engineering] öff-

Launch the local installed CTRLX  PLC  

ENGINEERING  by clicking on [Start ctrlX 

PLC Engineering]. 
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nen. 

 

 
[3.27] PLC > [Start ctrlX PLC Engineering] 

19 Projektnamen und Ordner wählen, in dem 

das SPS-Projekt gespeichert werden soll. 

Choose a project name and a folder where 

the PLC project should be saved. 

 

 
[3.28]  Start ctrlX PLC Engineering > Choose a project name and a folder 

20 Verbindung zum Data Layer über Wahl des 

Eintrags Edit > Online from ctrlX CORE… 

aus dem Kontextmenü des Eintrags 

„DataLayer_Realtime“ im Fenster Devices 

herstellen. 

Connect to Data Layer by choosing Edit > 

Online from ctrlX CORE… from the con-

text menu of “DataLayer_Realtime” in the 

window Devices. 
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[3.29] ctrlX PLC Engineering > Devices > “DataLayer_Realtime” > Edit > Online from ctrlX CORE… 

21 „ethercat_master_instances_eth[…]” aus-

wählen und mit [Apply changes] überneh-

men. 

Select “ethercat_master_instances_eth[…]” 

and apply by clicking [Apply changes]. 

 

 
[3.30] Edit online from ctrlX CORE > Select “ethercat_master_instances_ethercatmaster” > [Apply 

changes] 

22 Eintrag „_750_354” auswählen und mit 

[Apply changes] übernehmen. 

Select item “_750_354” and apply by click-

ing [Apply changes]. 
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[3.31] Edit online from ctrlX CORE > Select “_750_354” > [Apply changes] 

23 Alle Modul-Einträge auswählen und mit 

[Apply changes] übernehmen. 

Select all module items and apply by click-

ing [Apply changes]. 

 

 
[3.32]  Edit online from ctrlX CORE > Select all items > [Apply changes] 

24 Alle Kanal-Einträge auswählen und mit 

[Close] übernehmen. 

Select all channel items and apply by click-

ing [Close]. 
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[3.33] Edit online from ctrlX CORE > Select all items > [Close] 

25 Nach der erfolgreichen Einrichtung zeigt der 

Gerätebaum die hinzugefügten Geräte an. 

After successful setup, the device tree dis-

plays the added devices. 

 

 
[3.34] All I/O modules have been added to the window Devices 

26 Per Doppelklick auf „PLC_PRG (PRG)“ die 

Programmieroberfläche öffnen und die Va-

riablen im Deklarationsfenster (oben) anle-

gen und im Programmfenster (unten) aufru-

fen. 

Open the programming window by double 

click on “PLC_PRG (PRG)” and enter the 

variables in the declaration window (top) 

and call them in the programming window 

(bottom). 
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[3.35]  PLC_PRG: Variable declaration and programming 

27 Eingangsvariablen bInStart und 

bInStop den ersten beiden Eingangskanä-

len des Eingangsmoduls 

„_750_4xx_750_14xx_8b_in_“ zuweisen. 

Assign the input variables bInStart and 

bInStop to the first two input channels of 

the input module 

„_750_4xx_750_14xx_8b_in_“. 

 

 
[3.36] Assign input variables to input channels 

28 Ausgangsvariablen bOutError und 

bOutReady den ersten beiden Kanälen des 

Ausgangsmoduls 

„_750_5xx_750_15xx_8b_out_“ zuweisen. 

Assign the output variables bOutError 

and bOutReady to the first two channels of 

the output module 

“_750_5xx_750_15xx_8b_out_”. 
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[3.37] Assign input variables to input channels 

29 An der Steuerung über Online > Login 

oder über die Schaltfläche in der Werkzeug-

leiste anmelden und das Zertifikat der Steu-

erung der lokalen Verwaltung über [OK] 

hinzufügen. 

Log on to the PLC by Online > Login or by 

clicking the button in the toolbar and install 

the controller’s certificate in the local stor-

age by clicking on [OK]. 

 

 
[3.38] Online > Login  

 
[3.39] Online > Login > Install certificate 

30 Eine mögliche Abfrage zur Erzeugung der 

Applikation auf der Steuerung ist mit [Yes] 

zu bestätigen. 

A possible query for creating the application 

on the controller must be confirmed with 

[Yes]. 
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[3.40] Confirm the creation of the application 

31 Applikationsprogramm über Debug > Start 

oder über die Schaltfläche in der Werkzeug-

leiste starten. 

Start the application program by Debug > 

Start or by clicking the button in the toolbar. 

 

 
[3.41] Debug > Start 

32 Die Ansicht wechselt in den Online-Modus 

und Variablenwerte werden angezeigt und 

können gesetzt werden. 

The view switches to online mode and vari-

able values are displayed and can be set. 

 

 
[3.42] Online mode with variable values (bInStop has been set manually) 

33 SPS-Programm über File > Save speichern 

und CTRLX  PLC  ENGINEERING  verlas-

sen. 

Save the PLC program via File > Save and 

exit the CTRLX  PLC  ENGINEERING . 
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