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Schriftart Bedeutung // Font Conventions 
monospaced Namen von Pfaden und Dateien werden in 

einer Schriftart mit einheitlicher Zeichenbrei-

te dargestellt. Beispiel: notepad.exe 

Names of paths and data files are marked 

with a monospaced font. e.g.: 
notepad.exe 

Menu Menüpunkte werden fett dargestellt: Bei-

spiel: Speichern 

Menu items are marked in bold letters. e.g.: 

Save 

> Ein „Größer als“-Zeichen zwischen zwei 

Namen bedeutet die Auswahl eines Me-

nüpunktes aus einem Menü. Beispiel: Datei 

> Neu 

A greater-than sign between two names 

means the selection of a menu item from a 

menu. e.g.: File > New 

Eingabe Bezeichnungen von Eingabe- oder Aus-

wahlfeldern werden fett dargestellt. Beispiel: 

Wert 

Designation of input or optional fields are 

marked in bold letters, e.g.: Value 

„Wert“ Eingabe- oder Auswahlwerte werden in 

Anführungszeichen dargestellt. Beispiel: 

Geben Sie unter Messbereichsanfang den 

Wert „4 mA“ ein. 

Input or selective values are marked in 

inverted commas. e.g.: Enter the value “4 

mA” under Start of measurement range 

[Button] Schaltflächen und Tastenbeschriftungen auf 

der Tastatur werden fett dargestellt und in 

eckigen Klammern eingefasst. Beispiel: 

[OK] 

Pushbuttons in dialog boxes andy Keys are 

marked with bold letters in square brackets. 

e.g.: [OK] or [F5] 
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1. Einleitung // Introduction 

Ganz gleich, ob an der Verpackungsma-

schine oder am Roboterarm – die Module 

des WAGO  I /O  SYSTEM F IELD  in 

Schutzart IP67 finden sich genau dort, wo 

sie benötigt werden: direkt an der Maschine 

– nahe an Sensorik und Aktorik. 

Diese Anleitung zeigt auf, wie das WAGO  

I /O  SYSTEM F IELD  per EtherCAT mit 

dem CTRLX  CORE verbunden werden 

kann. 

Whether on the packaging machine or on 

the robot arm - the modules of the WAGO  

I /O  SYSTEM  F IELD  with IP67 protection 

are located exactly where they are needed: 

directly on the machine - close to sensors 

and actuators. 

This instruction shows how the WAGO  I /O  

SYSTEM F IELD  can be connected to the 

CTRLX  CORE via EtherCAT. 

2. Voraussetzungen // Prerequisites 

Diese Anleitung ist basierend auf This instruction has been created based on  

• CTRLX  CORE V1.10  

• CTRLX  CORE  ETHERCAT  MASTER APP  V1.10 

• CTRLX  PLC  ENGINEE RING  V1.10 

• CTRLX  I /O  ENGINEERING  V1.10  

• WAGO_series765.xml 

und exemplarisch mit folgenden Modulen aus 

dem WAGO  I /O  SYSTEM F IELD  erstellt 

worden: 

and exemplarily with the following modules 

from the WAGO  I /O  SYSTEM F IELD : 

• 765-4202/0100-0000 8-Port-IO Link Master Class B; EtherCAT; DC 24 V / 2.0 A 

• 765-1201/0100-0000   16-channel digital input; EtherCAT; 24 VDC 

• 765-1706/0200-0000   16-channel digital input/output; IO Link Class B Hub; 

 DC 24 V / 2.0 A 
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[2.1] WAGO I/O System Field  

3. Schritt-für-Schritt // Step by Step 

3.1 I/O-Konfiguration anlegen // Set up the I/O configuration 

01 CTRLX  CORE Benutzeroberfläche im 

Browser öffnen.5 

Open CTRLX  CORE user interface in 

browser. 
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[3.1] C T R L X  CORE  user interface 

 

02 EtherCAT-Master über Betätigung von [+] 

unter EtherCAT > Configuration hinzufü-

gen. 

Add EtherCAT master by clicking [+] in 

EtherCAT > Configuration. 

 

 
[3.2] EtherCAT > Configuration > [+]  
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[3.3] EtherCAT > Configuration > [+] > [OK] 

03 Das lokal installierte CTRLX  I /O  

ENGINEERING  über Betätigung der Schalt-

fläche [ctrlX I/O Engineering] öffnen. 

Launch the local installed CTRLX  I /O  

ENGINEERING  by clicking on [ctrlX I/O 

Engineering]. 

 

 
[3.4] EtherCAT > Configuration > [ctrlX I/O Engineering] 

04 Projektnamen und Ordner, in dem die I/O-

Konfiguration gespeichert werden soll, wäh-

Choose a project name and a folder where 

the I/O configuration should be saved. 
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len. 

 

 
[3.5]  Start ctrlX I/O Engineering > Choose a project name and a folder 

05 Sollte nach dem Start des CTRLX  I /O  

ENGINEERINGS  ein Dialog erscheinen, ist 

hier [Use project from ctrlX] zu wählen. 

If a window appears right after the start of 

CTRLX  I /O  ENGINEERIN G ,  please 

choose [Use project from ctrlX]. 

 

 
[3.6] ctrlX I/O Engineering > Project Synchronization 

06 Über Tools > Device Repository… die 

Gerätebeschreibungsdatei 

WAGO_series765.xml installieren. 

Install the device description file 

WAGO_series765.xml by selecting Tools 

> Device Repository… 
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[3.7] Tools > Device Repository… 

 

[3.8] Tools > Device Repository…> [Install] (Select the WAGO_series765.xml file to install.) 
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[3.9] Tools > Device Repository…> [Close] 

07 Aus dem Kontextmenü des Eintrags „ether-

catmaster“ den Menüpunkt Scan for De-

vices… auswählen, um die Module hinzu-

zufügen. 

Choose Scan for Devices… from the con-

text menu from the item “ethercatmaster” to 

add the modules. 

 

 
[3.10] “ethercatmaster” > Scan for devices… 

08 [Insert all newly scanned devices] betäti-

gen, und das Fenster mit [OK] schließen. 

Click [Insert all newly scanned devices] 

and close the window by clicking on [OK]. 
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[3.11] Scan for Devices… > [Insert all newly scanned devices] 

 
[3.12] Scan for Devices… > [OK] 
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[3.13] C T R L X  I /O  E N G I N E E R I N G  > Devices with two WAG O  I /O  S Y S T E M  F I E L D  modules 

09 Zur Konfiguration der IO-Link-Anschlüsse 

den Anschluss wählen und über das Kon-

textmenü Plug Device… aufrufen. 

To configure the IO-Link ports select a port 

and choose Plug Device… from its context 

menu. 

 

 
[3.14] Devices > Plug Device… 

10 Im Fenster die Belegung gemäß dem ange-

schlossenen Gerät wählen (hier ist am 

„IO_Link_port_X01“ ein IO-Link-Gerät mit 

jeweils zwei Byte in Lese- und Senderich-

tung angeschlossen). 

Select the data allocation according to the 

plugged device (here an IO-Link device with 

two bytes each in send and receive direc-

tion is plugged to “IO_Link_port_X01“). 
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[3.15] Devices > Plug Device… > Select the device configuration 

11 Konfiguration des IO-Link-Anschlusses 

(siehe Schritt 10) für jedes angeschlossene 

IO-Link-Gerät wiederholen (hier sind zwei 

Geräte am IO-Link-Modul angeschlossen). 

Repeat the configuration for the IO-Link port 

(see step 10) for each plugged IO-Link de-

vice (here are two devices connected to the 

IO-Link module). 

 

 
[3.16] Devices > Plug Device… > Select the device configuration 

12 Konfiguration über Wahl des Eintrags 

Transferring field bus configuration aus 

dem Kontextmenü des Eintrags „ethercat-

Apply configuration by choosing Transfer-

ring field bus configuration from the con-

text menu of “ethercatmaster”. 
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master“ übernehmen. 

Die eventuelle Frage nach einem Betriebs-

artenwechsel zu „Init“ ist mit [Yes] zu bestä-

tigen. 

In case of an upcoming question regarding 

the change of the operating mode to “Init” it 

must be confirmed by clicking [Yes]. 

 

 
[3.17] “ethercatmaster” > Transferring field bus configuration 

 
[3.18] Confirm the change of the operating mode to “Init” by clicking [Yes] 

13 I/O-Konfiguration über File > Save spei-

chern und CTRLX  I /O  ENGINEERING  

beenden. 

Save the I/O configuration via File > Save 

and exit the CTRLX  I /O  ENGINEERING . 

14 Status des EtherCAT-Feldbusses in der 

CTRLX  CORE Benutzeroberfläche unter 

EtherCAT > Status prüfen. 

Check the status of the EtherCAT fieldbus 

in the CTRLX  CORE user interface via 

EtherCAT > Status. 
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[3.19] ctrlX CORE > EtherCAT > Status 

15 Der Datenaustausch kann über System > 

Data Layer geprüft werden. 

In dem Beispiel sendet das an 

„IO_Link_Port_X02“ angeschlossene Gerät 

den Wert 2.053 aufgeteilt auf zwei Bytes 

(0x85). 

The data exchange can be checked using 

the System > Data Layer. 

In this example the device plugged to 

“IO_Link_Port_X02” sends the value 2.053 

splitted in two bytes (0x85). 

 

 
[3.20] ctrlX CORE > System > Data Layer 
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3.2 I/O-Signale in der SPS verwenden // Use the I/O signals in the PLC 

16 Das lokal installierte CTRLX  PLC  

ENGINEERING  über Betätigung der Schalt-

fläche [Start ctrlX PLC Engineering] öff-

nen. 

Launch the local installed CTRLX  PLC  

ENGINEERING  by clicking on [Start ctrlX 

PLC Engineering]. 

 

 
[3.21] PLC > [Start ctrlX PLC Engineering] 

17 Projektnamen und Ordner wählen, in dem 

das SPS-Projekt gespeichert werden soll. 

Choose a project name and a folder where 

the PLC project should be saved. 

 

 
[3.22]  Start ctrlX PLC Engineering > Choose a project name and a folder 

18 Verbindung zum Data Layer über Wahl des 

Eintrags Edit > Online from ctrlX CORE… 

aus dem Kontextmenü des Eintrags 

„DataLayer_Realtime“ im Fenster Devices 

herstellen. 

Connect to Data Layer by choosing Edit > 

Online from ctrlX CORE… from the con-

text menu of “DataLayer_Realtime” in the 

window Devices. 
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[3.23] ctrlX PLC Engineering > Devices > “DataLayer_Realtime” > Edit > Online from ctrlX CORE… 

19 „ethercat_master_instances_eth[…]” aus-

wählen und mit [Apply changes] überneh-

men. 

Select “ethercat_master_instances_eth[…]” 

and apply by clicking [Apply changes]. 

 

 
[3.24] Edit online from ctrlX CORE  >  Select “ethercat_master_instances_ethercatmaster”  >  [Apply 

changes] 

20 Alle Einträge auswählen und mit [Apply 

changes] übernehmen. 

Select all items and apply by clicking [Apply 

changes]. 
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[3.25] Edit online from ctrlX CORE > Select all items > [Apply changes] 

21 Alle IO-Link-Anschlüsse auswählen und mit 

[Apply changes] übernehmen. 

Select all IO-Link ports and apply by clicking 

[Apply changes]. 

 

 
[3.26]  Edit online from ctrlX CORE > Select all IO-Link ports > [Apply changes] 

22 Alle Kanal-Einträge auswählen und mit 

[Close] übernehmen. 

Select all channel items and apply by click-

ing [Close]. 
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[3.27] Edit online from ctrlX CORE > Select all items > [Close] 

23 Nach der erfolgreichen Einrichtung zeigt der 

Gerätebaum die hinzugefügten Geräte an. 

After successful setup, the device tree dis-

plays the added devices. 

 

 
[3.28] All I/O modules have been added to the window Devices 

24 Per Doppelklick auf „PLC_PRG (PRG)“ die 

Programmieroberfläche öffnen und die Va-

riablen im Deklarationsfenster (oben) anle-

gen und im Programmfenster (unten) aufru-

fen. 

Open the programming window by double 

click on “PLC_PRG (PRG)” and enter the 

variables in the declaration window (top) 

and call them in the programming window 

(bottom). 
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[3.29]  PLC_PRG: Variable declaration and programming 

25 Eingangsvariablen rawByte0 und 

rawByte1 den beiden Eingangskanälen 

des Anschlusses „IO_linkPort_X02“ des 

Moduls „_750_4202“ zuweisen. 

Assign the input variables rawByte0 and 

rawByte1 to the input channels of port 

“IO_Link_PortX02” of module „_750_4202“. 

 

 
[3.30] Assign input variables to input channels 

26 An der Steuerung über Online > Login 

oder über die Schaltfläche in der Werkzeug-

leiste anmelden und das Zertifikat der Steu-

erung der lokalen Verwaltung über [OK] 

hinzufügen. 

Log on to the PLC by Online > Login or by 

clicking the button in the toolbar and install 

the controller’s certificate in the local stor-

age by clicking on [OK]. 
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[3.31] Online > Login  

 
[3.32] Online > Login > Install certificate 

27 Eine mögliche Abfrage zur Erzeugung der 

Applikation auf der Steuerung ist mit [Yes] 

zu bestätigen. 

A possible query for creating the application 

on the controller must be confirmed with 

[Yes]. 

 

 
[3.33] Confirm the creation of the application 

28 Applikationsprogramm über Debug > Start 

oder über die Schaltfläche in der Werkzeug-

leiste starten. 

Start the application program by Debug > 

Start or by clicking the button in the toolbar. 

 

 
[3.34] Debug > Start 

29 Die Ansicht wechselt in den Online-Modus 

und Variablenwerte werden angezeigt. 

The view switches to online mode and vari-

able values are displayed. 
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[3.35] Online mode with variable values 

30 SPS-Programm über File > Save speichern 

und CTRLX  PLC  ENGINEERING  verlas-

sen. 

Save the PLC program via File > Save and 

exit the CTRLX  PLC  ENGINEERING . 
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